خطا در اجرای دستور react-native run-android

جمال جلالی

عضویت : 1397/10/09 پرسش ها : 3 پاسخ ها : 6

خطا در اجرای دستور react-native run-android

ارسال شده در : ‫۱۰ ماه قبل، سه شنبه ۳ اردیبهشت ۱۳۹۸، ساعت ۰۱:۵۴

سلام وقت بخیر 

زمان اجرای دستور  react-native run-android  با خطای زیر مواجه میشم . ابزار ضد تحریم 😀   هم فعاله

 


BUILD FAILED in 1s
error Could not install the app on the device, read the error above for details.
Make sure you have an Android emulator running or a device connected and have
set up your Android development environment:
https://facebook.github.io/react-native/docs/getting-started.html
error Command failed: gradlew.bat app:installDebug. Run CLI with --verbose flag for more details.

جمال جلالی

عضویت : 1397/10/09 پرسش ها : 3 پاسخ ها : 6

(پاسخ صحیح)

ارسال شده در :‫۱۰ ماه قبل، چهار شنبه ۴ اردیبهشت ۱۳۹۸، ساعت ۰۵:۱۰

ایرادی در آدرس دهی نیست 

تصویر خطا

 

0 تشکر

یونس قربانی

عضویت : 1396/09/19 پرسش ها : 0 پاسخ ها : 461
ارسال شده در :‫۱۰ ماه قبل، سه شنبه ۳ اردیبهشت ۱۳۹۸، ساعت ۱۴:۱۳

سلام دوست من

متغییر محلی ANDROID_HOME رو درست تعریف کردی ؟ ببین غلط املایی نداشته باشه

از اول چک کن

مشکلی بود در خدمتم

0 تشکر

یونس قربانی

عضویت : 1396/09/19 پرسش ها : 0 پاسخ ها : 461
ارسال شده در :‫۹ ماه قبل، یک شنبه ۸ اردیبهشت ۱۳۹۸، ساعت ۱۹:۱۱

خوب به نظر میرسه مشکل از JDK هست

نسخه ایی که در ویدئو گفتم رو نصب کنید و JAVA_HOME رو هم چک کنید (مثل ANDROID_HOME متغییر محیطی به نام JAVA_HOME بسازید و مسیر نصب JDK رو بدید بهش)

مشکلی بود در خدمتم

 

0 تشکر

جمال جلالی

عضویت : 1397/10/09 پرسش ها : 3 پاسخ ها : 6
ارسال شده در :‫۹ ماه قبل، جمعه ۱۳ اردیبهشت ۱۳۹۸، ساعت ۰۵:۵۳

سلام وقت بخیر 

بعد از کلی حذف و نصب نرم افزار متوجه شدم باید نرم افزارهای زیر نصب بشن تا react-native  بتونه پکیج هاش رو نصب کنه و اجرا بشه 

https://stackoverflow.com/questions/38889487/react-native-is-not-recognized-as-an-internal-or-external-command-operable-pr

npm install https://github.com/indexzero/forever/tarball/v0.5.6

نرم افزار git  : 

لینک نصب >>>>

https://git-scm.com/download/win  

آموزش نصبش در یوتیوب : https://git-scm.com/download/win  

کد خطا در استک : https://stackoverflow.com/questions/55450764/getting-the-following-error-while-executing-expo-init-command

امیدوارم مشکل دوستان هم باهاش حل بشه . 

 

1 تشکر

AliReZaZ

عضویت : 1398/01/17 پرسش ها : 26 پاسخ ها : 30
ارسال شده در :‫۸ ماه قبل، یک شنبه ۱۲ خرداد ۱۳۹۸، ساعت ۱۴:۳۱

سلام دوست عزیز منم دقیقا مشکل شما برام پیش امده اگر میشه دقیق توضیح بدید چطور میتونم رفعش کنم.

ممنون میشم

0 تشکر

جمال جلالی

عضویت : 1397/10/09 پرسش ها : 3 پاسخ ها : 6
ارسال شده در :‫۸ ماه قبل، دو شنبه ۱۳ خرداد ۱۳۹۸، ساعت ۱۰:۳۴

سلام 

مشکل اول من دانلود نشدن gradle  بود که اون رو دانلود کردم و توی پوشه اش اکسترک کردم   

بعد از git  رو خواست اونم نصب کردم و حلش شد 

0 تشکر

برای ارسال پاسخ باید وارد شوید و یا در سایت عضو شوید