• 1400/01/25

بخش article ها و تست اون :

سلام اقای خسروجردی خسته نباشید

نماز روزه هاتون قبول

دو روز پیش بخش پرسش و پاسخ یک کامنت گذاشتم نمیدونم چرا حذف شده

تو بخش article من تمام کدهاش نوشتم

ولی مثلا برای صفحه article ها چیزی نمایش نمیده طبق شکل زیر

http://localhost/admin-panel/article/ این ادرس ولی مثلا صفحه create مربوط به article ها رو میاره که تو اونجا نمیتونم پست که میخوام مثلا درج کنم category براش انتخاب کنم چون شما داخل ویدیو دوره به لیست category هاتون دسترسی داشتین 

لطفا راهنمایی بفرمایید

با تشکر

  • 1400/01/25
  • ساعت 21:07

دوست عزیز کدهایی که استاد تو فایل قرار دادن رو با کد های خودتون که نوشتید  مقایسه کنید 

و فایل index.php رو چک کنید که uri  رو براش تعریف کرده باشید چون وقتی هیچی نمیاره یعنی uri براش تعریف نکردین

 

 


  • 1400/01/26
  • ساعت 11:23

ببنید حالا اگر وقتی میخایید ایتمی رو اد کنید بدون اینکه ایتمی اد بشه ریدایرکت به صفحه اصلی میشه مشکل از کجاست؟ 


  • 1400/01/26
  • ساعت 11:44

سلام 

مرسی از دوستان 

صفحه index.php تابع uri اش قبلا چک کردم درست بود چون برای بخش category ها کامل کار میکنه در مورد این که بخوایم ایتمی اد کنیم بخش article ها به صفحه create میرم این صفحه ادرسش میاره ولی خب فیلد دوم که میگه این پست مربوط به کدوم category هستش رو چیزی داخل لیست نمایش نمیده که بخوام ریدایرکت بشم به صفحه اصلی و لیست article ها یا همون پست های admin رو ببینم 


  • 1400/01/26
  • ساعت 12:09

فک کنم سو تفاهم شد منم سوال پرسیدم 😂😂🙈


  • 1400/01/26
  • ساعت 12:13

خواهش میکنم


  • 1400/01/26
  • ساعت 12:26

ولی اقایی که سوال پرسیدید برای من چندین بار در طی پروژه این مشکل پیش اومد و‌رفتم مسیر رو بررسی کردم دیدم مشکل ازونجا بود 

منظورم  روتینگ‌( ادرس دهی هایی که نوشتید برای این کلاس) انتهای صفحه index 

چک کنید به احتمال خیلی زیاد ازونجاست (دقیق چک کنید پشیمون نمیشید) اگر مشکل سفید نشون دادن صفحه دارید اونطوری که من از عکستون دیدم 

*****تو ادرسی که اون بالا نوشتید بعد از ارتیکل چرا اسلش گذاشتید؟اونو پاک کنید اون اسلس که گذاشتید خودش صفحه سفید نمایش میده

حتی وقتی الان که باز یه تیبل جدید مینوشتم باز با همین صحنه مواجه شدم و طبیعتا روتینگ و بررسی کردم و حل شد 

 

در مورد اینکه چرا لیست کتگوری رو نشون نمیده که اگه قبلا ایتمی تو کتگوری اضافه کردید و الان نشون نمیده حتما به فانکشنی که نوشتید نگاه بندازید 

 

البته من خیلی عذر میخام که جواب دادم 🙏در حد مشکلاتی که خودم مواجه شدم و خیلی زمان برد تا حل بشن 

میدونم در این شرایط ادم خیلی به کمک احتیاج داره حتی ناچیز


  • 1400/01/26
  • ساعت 12:29

ی عکس از uri که نوشتید برای article میزارید 


  • 1400/01/26
  • ساعت 12:42

خیلی ممنون خواهش میکنم خوشحال میشم از تجربیات هم استفاده کنیم 

از راهنمایی تون خیلی ممنونم درست شد 

اون اسلش رو برداشتم الان صفحه مورد نظر رو اورد و بخش index هارو چک کردم اوکی شد

خیلی ممنونم 


  • 1400/01/26
  • ساعت 12:53

خواهش میکنم واقعا خوشحال شدم موفق باشید 🙏


  • 1400/01/26
  • ساعت 13:14

تشکر 


  • 1400/01/26
  • ساعت 15:26

با سلام خدمت شما همراه عزیز

 

 

سلامت باشید همچنین

 

 

من‌متوجه نشدم الان مشکل عزیزان حل شده یا خیر


  • 1400/01/26
  • ساعت 16:03

با سلام خدمت شما اقای خسروجردی عزیز

بله مشکلم حل شد

فقط یک سوال من هنوز رو کدهای پروژه تسلط کامل ندارم به نظرتون بعد از پایان دوره سعی کنم چند باری پروژه رو تمرین کنم یعنی خودم از اول کد بزنم بدون این که به ویدیو ها مراجعه کنم و وقتی کامل یاد گرفتم mvc رو شروع کنم یا همین دوره رو تموم کردم با php قاعدا یکم اشنا شدم mvc رو شروع کنم خودم نظرم این هستش که اول مفاهیم php خام رو که در پروژه داریم کار میکنیم رو کامل مسلط بشم؟


  • 1400/01/26
  • ساعت 16:04

با سلام خدمت شما همراه عزیز

 

 

تا وقتی یک پروژه صفر تا صد نزدید وارد mvc نشید چون سنگین هست


  • 1400/01/26
  • ساعت 16:22

ممنونم سلامت باشین 

چشم حتما تشکر میکنم


  • 1400/01/26
  • ساعت 17:54

استاد من یک سوال پرسیدم ولی بی جواب موند 

من قبلا هم تو بخش منو تو قسمت اینکه ایتمی اد نمیشه به منوم و به همون صفحه menu بدون اینکه ایتمی اد بشه ریدایرکت میشد شما دیتابیس فرستادید من ایمپورت کردم اوکی شد 

الان هم خودم ی تیبل درست کردم همه ی کاراشو انجام دادم صفحه create برام به نمایش در میاد باز هم وقتی میخوام ایتمی اد کنم بدون اینکه ایتمی اد بشه به همون صفحه ریدایرکت میشه 

نمیدونم چجوری حل کنم ؟ 


  • 1400/01/26
  • ساعت 21:06

خب خودتون میگید با ایمپورت کردن تیبل مشکلتون حل شد 

پس اسم فیلد ها رو بررسی کنید که درست وارد کرده باشید 

اگه مشکل از فیلد نبود از واردامپ استفاده کنید و کدهاتون رو بررسی کنید

سعی کنید خودتون بیشتر  دنبال مشکل بگردین زودتر دیباگ کردن رو یاد میگیرین


  • 1400/01/26
  • ساعت 23:58

من همه ی تلاشمو میکنم اگر نتونم حل کنم یا کلافه بشم سوال میپرسم یا جایی که ندونم از کجا باید شروع کنم سوال میپرسم 

 


  • 1400/01/27
  • ساعت 01:07

خب منم مشکل شما رو داشتم مشکل از کدم نبود بررسی که کردم  فهمیدم مشکل از اسم فیلد ها هست


  • 1400/01/28
  • ساعت 14:06

تعداد سوال جواباتون زیاد شده من نمیدونم مشکل حل شده یا خیر


logo-samandehi logo-anjoman-senfi